Informatica Workflow Error

Hi Experts,

We are working on OBIApps 7963 and we are completely new to Informatica. While running the Execution Plans through DAC we are getting  the below errors.

Test1

For Example, we can take the detail level information of SDE_ORA_ExchangeRateGeneral task.

Test2

And the Status Description is below.

————————————————————————-

2013-03-12 02:13:45.519 INFORMATICA TASK:SDE_ORAR1213_Adaptor:SDE_ORA_ExchangeRateGeneral_Full:(Source : FULL Target : FULL) has started.

ANOMALY INFO::: Error while executing : INFORMATICA TASK:SDE_ORAR1213_Adaptor:SDE_ORA_ExchangeRateGeneral_Full:(Source : FULL Target : FULL)
MESSAGE:::
Irrecoverable Error
Error while contacting Informatica server for getting workflow status for SDE_ORA_ExchangeRateGeneral_Full
Error Code = 36331:Unknown reason for error code 36331
Pmcmd output :

=====================================
STD OUTPUT
=====================================

Informatica(r) PMCMD, version [9.0.1 HotFix2], build [242.1111], LINUX 32-bit
Copyright (c) Informatica Corporation 1994 – 2010
All Rights Reserved.

Invoked at Tue Mar 12 02:14:06 2013

Connected to Integration Service: [EISBI_IS].
Integration Service status: [Running]
Integration Service startup time: [Tue Jan 29 22:41:20 2013]
Integration Service current time: [Tue Mar 12 02:14:06 2013]
Folder: [SDE_ORAR1213_Adaptor]
Workflow: [SDE_ORA_ExchangeRateGeneral_Full] version [5].
Workflow run status: [Failed]
Workflow run error code: [36331]
Workflow run error message: [WARNING: Session task instance [SDE_ORA_ExchangeRateGeneral_Compress_Full] failed and its “fail parent if this task fails” setting is turned on. So, Workflow [SDE_ORA_ExchangeRateGeneral_Full] will be failed.]
Workflow run id [11333].
Start time: [Tue Mar 12 02:13:46 2013]
End time: [Tue Mar 12 02:13:47 2013]
Workflow log file: [/d02/informatica/server/infa_shared/WorkflowLogs/SDE_ORA_ExchangeRateGeneral_Full.log]
Workflow run type: [User request]
Run workflow as user: [Administrator]
Run workflow with Impersonated OSProfile in domain: []
Integration Service: [EISBI_IS]
Disconnecting from Integration Service

Completed at Tue Mar 12 02:14:06 2013

=====================================
ERROR OUTPUT
=====================================
Re-Queue to attempt to run again or attach to running workflow
if Execution Plan is still running or re-submit Execution Plan to execute the workflow.
EXCEPTION CLASS::: com.siebel.analytics.etl.etltask.IrrecoverableException

com.siebel.analytics.etl.etltask.InformaticaTask.doExecute(InformaticaTask.java:179)
com.siebel.analytics.etl.etltask.GenericTaskImpl.doExecuteWithRetries(GenericTaskImpl.java:410)
com.siebel.analytics.etl.etltask.GenericTaskImpl.execute(GenericTaskImpl.java:306)
com.siebel.analytics.etl.etltask.GenericTaskImpl.execute(GenericTaskImpl.java:213)
com.siebel.analytics.etl.etltask.GenericTaskImpl.run(GenericTaskImpl.java:585)
com.siebel.analytics.etl.taskmanager.XCallable.call(XCallable.java:63)
java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
java.util.concurrent.FutureTask.run(FutureTask.java:138)
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
java.util.concurrent.FutureTask.run(FutureTask.java:138)
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
java.lang.Thread.run(Thread.java:662)

(Number of retries : 1)

pmcmd startworkflow -sv EISBI_IS -d Domain_eld17.eistech.com -u Administrator -p **** -f SDE_ORAR1213_Adaptor -lpf /d02/informatica/server/infa_shared/SrcFiles//ORA_R1213.DataWarehouse.SDE_ORAR1213_Adaptor.SDE_ORA_ExchangeRateGeneral_Full.txt SDE_ORA_ExchangeRateGeneral_Full

2013-03-12 02:14:07.21 INFORMATICA TASK:SDE_ORAR1213_Adaptor:SDE_ORA_ExchangeRateGeneral_Full:(Source : FULL Target : FULL) has finished execution with Failed status.

—————————————————

THe WF is below.

WF-Exch_Rate_General

WF Properties Tab:

WF-Exch_Rate_General.2

WF Mappins- Connections tab:

WF-Exch_Rate_General.1

When we run the WF from the Task, we are getting the below Failed status.

WF-Exch_Rate_General.3

THe WF log is below and we are unable to get SessionLog.

WF-Exch_Rate_General.4

As of my knowledge all the connctions are fine..  🙂

But, we are getting the below error:

Restart Workflow: ERROR: Workflow [SDE_ORA_ExchangeRateGeneral]: Execution failed.  Please check the workflow log for more information.

But, still we are unable to load the data for the Target tables.

Please guide me, where i missed the connections or doing mistakes.

Appreciate your help here.

Raghu Nagadasari

Advertisements

About raghunagadasari

Working with a MNC on BI Applications 7.9.6x, OBIA 11.1.1.7.1. Having work exp on EBS, Oracle Apps, ODI, Informatica, OBIEE, Pl/sql,
This entry was posted in Informatica. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s